PXE, eth=IP at boot and THTTP root directory problems

You can report problems, make suggestions, about the new BETA versions in this forum. For stuff related to final releases, please post a message in other forums
Post Reply
nickwe
Posts: 8
Joined: 24 Dec 2009, 17:03

PXE, eth=IP at boot and THTTP root directory problems

Post by nickwe » 10 Aug 2010, 19:44

I'm using sysrcd 1.6 beta 13 on USB stick (installed from usb_inst.sh), exactly the same problems happen on two different laptops

Sorry for the big image file, I've grouped all my screenshots:

http://img196.imageshack.us/img196/9725 ... creens.jpg
  • 1 & 2: When I append eth0=192.168.1.5 to the boot option, it sees it but it does not applied the IP :-(
  • 4, 5 & 6: When I start the service pxebootsrv, I always have to do the following commands in that orders to make it work:
    * Setup IP: ifconfig eth0 192.168.1.5
    * Start the services: /etc/init.d/pxebootsrv (Failed because it loose the IP)
    * Setup IP again: ifconfig eth0 192.168.1.5
    * Start the services again: /etc/init.d/pxebootsrv (never failed on the second time!)
  • 3 & 6: While I don't make any modifications to the /etc/conf.d/pxeboot.cfg file and that I asked to start THTTP, it doesn't start it (that was working in sysrcd 1.5.7). So I need to start it manually and then only it would work.
  • 7 & 8: When I start a remote system trough PXE, I have the same problem when I append the option eth0=IP at the boot command line. In a first time, it seems to configure it, but at the end, it take an IP from the DHCP range :-(
  • 9, 10, 11 & 12: The root directory of the THTTP server is not the /tftboot directory anymore (like it was for sysrcd 1.5.7), but it seems now to be the /livemnt/boot which is read-only, so impossible to put any autorun script :-(
    * So where can we specify the root directory?
I don't know if I'm doing anything wrong (this is why I took a lot of screenshots), but that seems to be still very buggy for a beta13. Don't hesitate to ask me anything to test.

Regards,


Nicolas.

fastoche
Posts: 7
Joined: 06 Apr 2010, 15:13

Re: PXE, eth=IP at boot and THTTP root directory problems

Post by fastoche » 13 Aug 2010, 09:55

Hi,
The problem is that the network manager (DHCP client) is start. Just put "nonm" option at boot time.

Fastoche

nickwe
Posts: 8
Joined: 24 Dec 2009, 17:03

Re: PXE, eth=IP at boot and THTTP root directory problems

Post by nickwe » 15 Aug 2010, 18:58

Argh, I just figured it out that NetworkManager was removing the IP but didn't know how to disable it (I'll search the wiki for documentation about this nonm option) without remastering the iso image or by using the backstore option, so I finally end it up by creating an autorun script that would set up the IP :-( I'll use your option which is much cleaner, thanks for pointing me in the right direction!

And for the root directory of the thttp root directory being not writeable as I wanted, I was modifying the wrong file:

/etc/thttp/thttp.conf

instead of

/etc/conf.d/thttp

In the latest file, there is a variable where to change the root directory, so I set it up to my backstore partition.

So know everything is working fine on 1.5.7, will try 1.6 when it will come out.

Thanks again fastoche,


Nicolas.

nickwe
Posts: 8
Joined: 24 Dec 2009, 17:03

[Solved] PXE, eth=IP at boot and THTTP root directory proble

Post by nickwe » 15 Aug 2010, 20:41

From this page

http://www.sysresccd.org/Sysresccd-manual-en_Network

it is said that
If you are booting SystemRescueCd from the network or if you are using boot options such as ethx or dodhcp the Network-Manager service will automatically be stopped.
This is definitely not the case (for neither of the two options) so unless you specify nonm as a boot option, NetworkManager will always start (at least for me with 1.5.7 and 1.6.0 beta 13).

Regards,


Nicolas.

Post Reply