Spelling error with usb install

You can report problems, make suggestions, about the new BETA versions in this forum. For stuff related to final releases, please post a message in other forums
Post Reply
xerxes2
Posts: 3
Joined: 05 Aug 2010, 14:45

Spelling error with usb install

Post by xerxes2 » 05 Aug 2010, 14:51

Hi!

There seems to be a spelling error on the "install-mbr" program when using the "usb_inst.sh" script. "install-mbr" is called "install_mbr" and that causes the script to fail. I managed to get through it with renaming the file before pressing "ok " in the dialog window but it took me a while to figure it out.

admin
Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Re: Spelling error with usb install

Post by admin » 07 Aug 2010, 14:05

Sorry, I don't see where you have found "install_mbr" (with an underscore).
I can only see references to "install-mbr"

xerxes2
Posts: 3
Joined: 05 Aug 2010, 14:45

Re: Spelling error with usb install

Post by xerxes2 » 09 Aug 2010, 17:49

It's the file that is on the iso that is spelled wrongly and that causes the "usb_inst.sh" script to fail. Another guy told me that it might be the command that makes your iso that screws up hyphens and makes them underscores instead.

sander
Posts: 7
Joined: 16 Nov 2008, 18:52

Re: Spelling error with usb install

Post by sander » 10 Aug 2010, 10:02

- Which version of systemrescuecd are you using?
- How are you mounting it? The standard iso9660 volume descriptor (rightly) lists the file you mention as "install_mbr" (see http://en.wikipedia.org/wiki/ISO_9660 for details about the characters allowed). The Rock Ridge volume descriptor lists it as the intended "install-mbr". Most linux distributions automatically use Rock Ridge when present, but perhaps this is not the case in your situation.

xerxes2
Posts: 3
Joined: 05 Aug 2010, 14:45

Re: Spelling error with usb install

Post by xerxes2 » 10 Aug 2010, 13:29

Hey thanks sander, that was the problem. I'm using a very old kernel config oin this box and for some reason joliet wasn't chosen but I just recompiled it and now it works so there's no error on the sysrescue iso.

sander
Posts: 7
Joined: 16 Nov 2008, 18:52

Re: Spelling error with usb install

Post by sander » 10 Aug 2010, 21:34

HTH. Thanks for correcting me by the way, I was quite sure sysrcd used Rock Ridge, but you're right, it uses Joliet.

Post Reply