LCD turned off on Sony VAIO VPCZ1 (Z-Series) (1.60-beta006)

You can report problems, make suggestions, about the new BETA versions in this forum. For stuff related to final releases, please post a message in other forums
tormen
Posts: 8
Joined: 12 May 2005, 07:25

LCD turned off on Sony VAIO VPCZ1 (Z-Series) (1.60-beta006)

Postby tormen » 28 Jul 2010, 17:20

Hi,

Like my colleague (with the Thinkpad) same here, just that an acpi=off did not help.

The text scrolls by so fast that I am not even able to tell you at what point it blanks.

Any ideas?

Thanks!

tormen

tormen
Posts: 8
Joined: 12 May 2005, 07:25

Re: LCD turned off on Sony VAIO VPCZ1 (Z-Series) (1.60-beta0

Postby tormen » 28 Jul 2010, 17:28

FYI: The notebook has 2 graphic cards: on-board intel + nvidia
I just got the notebook yesterday + there is still only windows in stalled on it yet --> I don't have any more details yet. Let me know if and what you would need.

I just noticed: With acpi=off: I think the nvidia ( / nouveau? ) did NOT get loaded (because there are LEDS indicating which graphic is in use and they don't light up at all,
where without the acpi=off the "Speed" LED and the "AUTO" LED are lit, which seems to indicate that nvidia is in use (at least under windows). The latter with the LEDs happened in hardware-switch position "AUTO" and "STAMINA". "Stamina" means use Intel on board (under windows).

Best,

tormen.

linuxjacques
Posts: 2
Joined: 28 Jul 2010, 18:33

Re: LCD turned off on Sony VAIO VPCZ1 (Z-Series) (1.60-beta0

Postby linuxjacques » 28 Jul 2010, 18:44

Hi,

I have the same laptop (just got it a week ago). I have the same issue.

There are known issues with the Z hybrid graphics, as well as the Intel Arrandale graphics, under linux.

For example, see: https://bugs.freedesktop.org/show_bug.cgi?id=29141

There is an updated sony-laptop module which can (maybe) enable/disable the two video hardware modes:

git://gitorious.org/sony-laptop-zseries ... series.git

Another good link is: https://lists.launchpad.net/sony-vaio-z-series/

It looks like things won't really get much better for the Z until 2.6.35.

jacques

admin
Site Admin
Posts: 2707
Joined: 17 Jul 2003, 09:44

Re: LCD turned off on Sony VAIO VPCZ1 (Z-Series) (1.60-beta0

Postby admin » 03 Aug 2010, 19:27

Is that working better in new sysresccd-1.6.0-beta version, now that the nouveau driver has been removed ?

tormen
Posts: 8
Joined: 12 May 2005, 07:25

Re: LCD turned off on Sony VAIO VPCZ1 (Z-Series) (1.60-beta0

Postby tormen » 04 Aug 2010, 15:39

Nope, does not change a thing. Starting with default grub selection + without any further kernel parameter changes --> blank screen during loading of modules part (which module I can't tell).

Could you try to use the released 2.6.34.2 kernel, because it has some fixes that are specifically target some problems with intel arrandale being BLANK...

or the 2.6.35 ... as linuxjacques seems to believe that this could work better ...

linuxjacques
Posts: 2
Joined: 28 Jul 2010, 18:33

Re: LCD turned off on Sony VAIO VPCZ1 (Z-Series) (1.60-beta0

Postby linuxjacques » 04 Aug 2010, 16:50

I'm sorry I have not been able to test this yet on my laptop.

tormen, did you try booting with the alternate (2.6.35) kernel in the latest beta?

2.6.35 and 2.6.34.2 _appear_ (not 100% sure) to have the same Arrandale fixes.

admin
Site Admin
Posts: 2707
Joined: 17 Jul 2003, 09:44

Re: LCD turned off on Sony VAIO VPCZ1 (Z-Series) (1.60-beta0

Postby admin » 04 Aug 2010, 21:16

You can try the 2.6.35 kernel which is the default kernel (rescuecd + rescue64) in the latest sysresccd-1.6.0-beta version.

tormen
Posts: 8
Joined: 12 May 2005, 07:25

Re: LCD turned off on Sony VAIO VPCZ1 (Z-Series) (1.60-beta0

Postby tormen » 04 Aug 2010, 23:32

admin wrote:You can try the 2.6.35 kernel which is the default kernel (rescuecd + rescue64) in the latest sysresccd-1.6.0-beta version.


Thanks for the answers!

I actually tried the .11 (downloaded, burned iso today) --> it should be the kernel 2.6.35.

Unfortunately as I said: blank screen somewhere while the modules are loaded.

Are there maybe any kernel parameters I could try?

Thanks!

tormen
Posts: 8
Joined: 12 May 2005, 07:25

Re: LCD turned off on Sony VAIO VPCZ1 (Z-Series) (1.60-beta0

Postby tormen » 04 Aug 2010, 23:35

... or someway to make boot up slow(er) / interactive so that I can see what fails and then maybe exclude this module?

tormen
Posts: 8
Joined: 12 May 2005, 07:25

Re: LCD turned off on Sony VAIO VPCZ1 (Z-Series) (1.60-beta0

Postby tormen » 05 Aug 2010, 12:35

The no KMS option works - but then I have no X (load module glx, fbdev failed) ;)


Return to “Beta versions (report a bug found in a beta)”

Who is online

Users browsing this forum: No registered users and 2 guests