Installer for Windows 2.0.0 modifies hard disk boot sector

Post there if you have problem when downloading the iso, or burning it.
hoylen
Posts: 1
Joined: 16 Apr 2014, 01:31

Installer for Windows 2.0.0 modifies hard disk boot sector

Postby hoylen » 16 Apr 2014, 01:50

The SystemRescueCd installer for Windows [1] has a bug where it modifies the boot sector of the Windows hard disk that it is running on.

I was running the installer to install the SysRescCD 4.1.0 ISO image onto a USB memory stick. The first time I ran it, Windows XP raised a dialog box saying that the application requires permission to do something dangerous, so I said no. The USB stick failed to boot (probably should be another bug report, but I can't supply any useful information other than it didn't work). So I ran it again, and this time I said yes. That USB stick also failed to boot. But then I discovered my Windows XP hard disk now boots to Grub 2.0 -- the installer was modifying the boot sector of the hard disk and not that of the USB stick! This is a bug: it should not modify the hard disk, only the USB memory stick.

Also, the instructions [2] for using the SystemRescueCd installer for Windows is missing a step. You must extract the ISO into the temporary directory first, before you can install it to the USB stick.

[1] http://www.sysresccd.org/download/sysre ... -2.0.0.exe
[2] http://www.sysresccd.org/Sysresccd-manu ... _USB-stick

Correction: it is not the boot sector on the hard disk that gets written to. I've repaired the Master Boot Record (MBR) and it still boots to Grub. It is probably the boot sector of the Windows partition on the hard disk that got written to. So far I haven't found a way of fixing the problem, so have to boot Windows XP by typing "exit" in Grub's command line.

Return to “Downloading and burning”

Who is online

Users browsing this forum: No registered users and 1 guest