has 2 bugs [solved]

Post there if you have problem when downloading the iso, or burning it.
Posts: 1
Joined: 05 Nov 2012, 05:16 has 2 bugs [solved]

Postby ttusi » 05 Nov 2012, 05:36

in the ver 3.1.0 image has an script.

When I run with dialog, then broken.

I run this script with every step:

1. BUG:
[email protected]:/mnt/cdrom# ./ writembr /dev/sdc
The device [/dev/sdc] seems to be big enough: 3823 MB.
--> /var/tmp/usb_inst.tmp/install-mbr /dev/sdc --force
--> /var/tmp/usb_inst.tmp/parted -s /dev/sdc mklabel msdos
--> /var/tmp/usb_inst.tmp/parted -s /dev/sdc mkpart primary fat32 0 100%
Error: Unknown file system type "fat32". error: /var/tmp/usb_inst.tmp/parted -s /dev/sdc mkpart primary fat32 0 100% --> failed

When I run with my Ubuntu 12.04 systems's parted, that makes everythings very well:
parted -s /dev/sdc mkpart primary fat32 0 100%

[email protected]:/mnt/cdrom# parted -s /dev/sdc mkpart primary fat32 0 100%
Warning: The resulting partition is not properly aligned for best performance.

2. BUG
[email protected]:/mnt/cdrom# ./ copyfiles /dev/sdc1
”./usbstick.htm” -> ”/mnt/usbstick/usbstick.htm”
”./version” -> ”/mnt/usbstick/version”
Files have been successfully copied to /dev/sdc1
sed: can't read /mnt/usbstick/boot/grub/grub.cfg: No such file or directory
[email protected]:/mnt/cdrom#

I found grub310.cfg in this place. I copied to grub.cfg, and the sed run successfully.

Site Admin
Posts: 2715
Joined: 17 Jul 2003, 09:44

Re: has 2 bugs

Postby admin » 05 Nov 2012, 18:29

Thanks all bugs have been fixed in SystemRescueCd-3.1.1-beta002

Return to “Downloading and burning”

Who is online

Users browsing this forum: No registered users and 2 guests