Is there something missing in the USB install instructions?

Post there if you have problem when downloading the iso, or burning it.
openick
Posts: 1
Joined: 17 Dec 2010, 14:14

Is there something missing in the USB install instructions?

Postby openick » 17 Dec 2010, 14:32

I followed the instructions at page http://www.sysresccd.org/Sysresccd-manu ... _USB-stick

Mount the CD-ROM ISO image
You first have to mount the ISO image (or a media where you have burned it). You just need an empty directory on your system on which the ISO image can be mounted. We will use /tmp/cdrom in this example but you can use any directory such as /mnt/cdrom:
mkdir -p /tmp/cdrom
mount -o loop,exec /path/to/systemrescuecd-x86-x.y.z.iso /tmp/cdrom
Plug in the USB stick
Just make sure the USB stick has been plugged in, and wait a few seconds to be sure the device has been detected by the system.
Execute the installer
Now you just have to execute the installation script which is at the root of the CD-ROM. This script requires several commands to run but it won't be a problem. To be sure the script will always work, these commands are part of the CD-ROM:
cd /tmp/cdrom
bash ./usb_inst.sh
This script will show you a list of USB sticks detected on your system. Only removable medias are in the list. This way it's not possible to destroy a persistent device by accident.

>>>>//Is there something missing here? There are no instructions about copying the iso file to the usb drive //

Unmount the ISO image
Now you can unmount the ISO image
cd ~
umount /tmp/cdrom



After this the instructions are to unmount the ISO image. There are no instructions as to how to copy the iso file on to USB drive.

[email protected]:/home/dirub# mount -o loop,exec /home/dirub/Downloads/systemRescue/systemrescuecd-x86-1.6.4.iso /tmp/cdrom
[email protected]:/home/dirub# cd /tmp/cdrom
[email protected]:/tmp/cdrom# bash ./usb_inst.sh
Device [/dev/sdb] detected as [SanDisk Cruzer Blade ] is removable and size=3835MB
* Device [/dev/sdb] is mounted: cannot use it
All valid USB/Removable devices are currently mounted, unmount these devices first
[email protected]:/tmp/cdrom# ls /dev/sdb
/dev/sdb
[email protected]:/tmp/cdrom# sudo fuser -km /dev/sda
[email protected]:/tmp/cdrom# umount /dev/sda
umount: /dev/sda: not mounted
[email protected]:/tmp/cdrom# bash ./usb_inst.sh
Device [/dev/sdb] detected as [SanDisk Cruzer Blade ] is removable and size=3835MB
* Device [/dev/sdb] is mounted: cannot use it
All valid USB/Removable devices are currently mounted, unmount these devices first
[email protected]:/tmp/cdrom# ls /mnt/usb
ls: cannot access /mnt/usb: No such file or directory
[email protected]:/tmp/cdrom# umount /dev/sda
umount: /dev/sda: not mounted
[email protected]:/tmp/cdrom# bash ./usb_inst.sh
Device [/dev/sdb] detected as [SanDisk Cruzer Blade ] is removable and size=3835MB
* Device [/dev/sdb] is mounted: cannot use it

gernot
Posts: 1125
Joined: 07 Apr 2010, 16:19

Re: Is there something missing in the USB install instructio

Postby gernot » 17 Dec 2010, 16:17

its not /dev/sdb what is mounted. sdb is the device.
i think /dev/sdb1 (partition) is mounted.

If you use a graphical systen try to "eject" or unmount via gui or use
umount /dev/sdb1

Gernot

mpictor
Posts: 2
Joined: 30 Dec 2010, 21:54

Re: Is there something missing in the USB install instructio

Postby mpictor » 30 Dec 2010, 21:56

* Device [/dev/sdb] is mounted: cannot use it
All valid USB/Removable devices are currently mounted, unmount these devices first


Right there is your problem


Return to “Downloading and burning”

Who is online

Users browsing this forum: No registered users and 1 guest